Re: DEB Package?

Sorry, I should have mentioned more clearly that I am running AMD64. I was trying to compile with 0.2.0, so that would explain a lot of my issues. I *would* like to have a native 64 bit binary, but it sounds like that isn’t going to happen right now. I have ia32-lib already, I’ll try running what you’ve supplied, and failing that Wine might be an option. Thanks for the help. I don’t remember coming across SVN links on the download page, but once you get up to wxWidgets2.9 I may try again. I could *not* get 2.8.10 to compile for me, I’m sure I probably was overlooking something, but it sounds like 2.9 at least resolves the utf-8/ansi issue 🙂

I couldn’t get wxWidgets 2.8.9 to compile on Karmic 64-bit either.

I have been compiling the latest SVN on Karmic 64-bit with wxWidgets 2.9.0, which compiles fine on 64-bit.  Read build-unix.txt and use the given ../configure parameters on wxWidgets so you can use the makefile.unix.wx2.9 as supplied.  (–enable-debug –disable-shared –enable-monolithic)

There’s one cosmetic bug with 2.9.0 I still need to fix where the status number display is bunched up for some reason.  — fixed

The download link on the homepage is to the sourceforge tar.gz archive which contains the 32-bit binary and the 0.2.0 sources, which were not yet buildable on 64-bit at the time.

The SVN was first buildable on 64-bit with wx2.9.0 on 28 January 2010.

Hopefully they’ll have a wxWidgets 2.9.0 debian package someday.

33,281 total views, 16 views today

https://bitcointalk.org/index.php?topic=49.msg326#msg326